[RPZ] 9.9.3-rpz2+rl.150.20 fails to launch "due to assertion failure"

darx+dnsrpz at sent.com darx+dnsrpz at sent.com
Fri May 31 04:26:56 UTC 2013

On Thu, May 30, 2013, at 08:48 PM, Vernon Schryver wrote:
> What happened to the previous version? 

I package my builds with checkinstall.  They're installed as rpms.

Before installing one, I uninstall the other, rm'ing all traces.

There's only one install path.

> In other words, have you checked
> with `find / -name named` just to be absolutely certain?


> I've assumed that the crash is consistent.  Is that true?

Yes.  At each/every launch.

> That named.conf file, with the response-policy{} statement wrapped
> in options{}; does not crash for me.


> I've not figured out all of those many ./configure settings, but their
> number is worrisome.  I learned decades ago to change the absolute
> minimum number of knobs and buttons and to try very hard to use the
> defaults in any package.  You can hope that the defaults have been
> smoke tested and are in use elsewhere.  The farther you get from the
> defaults, the more likely that you are doing something unique and will
> encounter unique problems.


Nonehteless, this config has been working for me for ages.  It works now
with 9.9.2-P2.

9.9.3 is a 'new' fail.

> Is the named.run file missing or does it not contain a stack trace?

I can't manage to *find* either a 'named.run' file, or a 'core' file.

> As the ARM says:
>     channel default_debug {
> 	// write to named.run in the working directory
> 	// Note: stderr is used instead of "named.run" if
> 	// the server is started with the '-f' option.
> 	file "named.run";
> and
>     The default_debug channel has the special property that it only
>     produces output when the server's debug level is nonzero. It
>     normally writes to a file called named.run in the server's
>     working directory.

Aha.  I'd thought the named.run was a renamed core dump file ...

so, adding "-d 90" to launch options still doesn't seem to help.  It
seems it never gets as far as logging.  I'm not sure I believe that, and
will keep poking at it ...

> The first thing the ISC people will ask is whether the crash happens
> without the patch.

Right.  This is just my 1st shot at comparing apples-n-apples.

I'm asking here 1st, as my prior setup -- with *patched* Bind -- is
known to work with the in-place named.conf.

Switching from patched 9.9.2-P2 -> patched 9.9.3 is what manifests this
particular problem.

>  Because the named.conf fragment does not use any
> RPZ features that are not in the unpatched 9.9.3 and does not mention
> RRL, it looks as if that should not be a problem.

That's my copy/paste mistake; sorry.

My named.conf DOES also include:

  rate-limit {
    responses-per-second 5;
    window 5;

> The RPZ tests are another thing to try:
>    cd .../bin/tests/system
>    su -c "sh ifconfig.sh up"
>    sh run.sh rpz
> There are also RRL tests that can be run by `sh run.sh rrl` after
> the interfaces are set up with ifconfig.sh

More information about the DNSfirewalls mailing list